build议在12.04 LTS上使用Ubuntu 14.04 LTS吗?

我不确定如何提出这个问题,但是我正在切换托pipe公司,并且要迁移一切。 我可能会手动设置一切,没有复制粘贴工作,除了普通的文件。 但是,我的旧服务器是在当时最新的Ubuntu 12.04上安装的,但是在这个时候,Ubuntu 14.04就已经发布了。 现在我不能确定是应该保持在12.04还是升级到14.04以保证性能/安全或其他相关的原因。

我不是一个服务器程序员,而是一个前端开发人员,所以我的命令行技能等于我的谷歌search技能,我想我必须做相同数量的search才能使所有的工作在Ubuntu 14.04上至于Ubuntu 12.04 ..(哦,我不支付一个支持计划,所以一切都由我自己)

虽然这可能是自以为是的答案,但请根据尽可能多的事实回答,关于StackExchange规则。

提前致谢!

服务器内容说明一个带有Zpanelpipe理面板的服务器(需要12.04,因此14.04不会成为一个选项,但是仍然有兴趣!)和一个MySQL数据库。 我将在其上运行静态网站和Wordpress。 我也会通过DoveCot / Postfix在其上运行一个电子邮件服务器。所以这很简单,我想,没有什么特别的或特殊的。

  • apache kerberosauthentication票据在klist下不可见
  • 无人参与升级日志
  • Samba / CIFS Ubuntu 14.04挂载错误(112)
  • Ubuntu Server 14.04 LTS与KVM的虚拟化限制?
  • 与ASA的Strongswan RA和Strongswan站点2站点
  • /etc/hosts.deny在Ubuntu 14.04中被忽略
  • 3 Solutions collect form web for “build议在12.04 LTS上使用Ubuntu 14.04 LTS吗?”

    性能的原因

    性能很大程度上取决于您正在运行的实际应用程序。 如果在性能方面有特定的内核改进,您可以利用LTS启用堆栈来获取更高版本的内核版本和关联的程序

    安全的原因

    鉴于12.04是LTS版本,支持包中的任何安全修补程序将被反向移植到12.04。


    为了尽量减less您的环境风险和变化,我build议坚持12.04。

    就性能而言,2012年到2014年间,Linux内核,glibc以及您在内核和应用程序之间遇到的所有其他层面都发生了很多变化。

    如果你的应用程序是真正的微调的,而它下面的一切都是真正的瓶颈,那么升级到14.04可能会对你有所帮助。 这是不太可能的,大部分时间来说,性能的瓶颈是你自己需要的应用程序,而不是底层的软件/库/内核。

    如果你确定你的软件是如此顶级的钻石,绝对可以通过升级到最新的软件在性能方面获得巨大的改善,那就去做吧。 如果不是这样,坚持12.04 LTS。

    如果您有空闲时间/资源,只需将您的软件安装到14.04 LTS,对其进行基准testing(并对QA进行testing,看看它是否有效),然后查看升级是否可以获得某些东西。

    无论您的情况如何,如果您知道您的软件是如何在最近的一些操作系统/ Linux发行版上执行的,那么它绝不会受到伤害。

    我觉得应该用一种不同的实用主义观点而不是技术来衡量一下。

    既然你是依靠谷歌和社区的支持,从现在开始的一到两年,你将更有可能find合适的新软件包的帮助,14.04比12.04

    虽然现在相反可能是真的

    值得考虑到方程imho

    服务器问题集锦,包括 Linux(Ubuntu, Centos,Debian等)和Windows Server服务器.