在CentOS 7中更新Yum时的依赖冲突

在新安装的CentOS 7操作系统上,我试图运行yum更新时出现这个错误

Processing Conflict: kernel-3.10.0-514.6.1.el7.x86_64 conflicts kmod < 20-9 --> Finished Dependency Resolution Error: Package: firefox-45.6.0-1.el7.centos.x86_64 (updates) Requires: nspr >= 4.11.0 Installed: nspr-4.10.8-2.el7_1.x86_64 (@anaconda) nspr = 4.10.8-2.el7_1 Error: Package: nss-3.21.3-2.el7_3.x86_64 (updates) Requires: nss-softokn(x86-64) >= 3.16.2.3-14.2 Installed: nss-softokn-3.16.2.3-13.el7_1.x86_64 (@anaconda) nss-softokn(x86-64) = 3.16.2.3-13.el7_1 Error: Package: 1:libguestfs-1.32.7-3.el7.centos.2.x86_64 (updates) Requires: supermin5 >= 5.1.16-2 Installed: supermin5-5.1.10-1.2.el7.x86_64 (@anaconda) supermin5 = 5.1.10-1.2.el7 Error: Package: libsemanage-2.5-5.1.el7_3.x86_64 (updates) Requires: libsepol.so.1(LIBSEPOL_1.0)(64bit) Error: Package: libsemanage-2.5-5.1.el7_3.x86_64 (updates) Requires: libsepol.so.1(LIBSEPOL_1.1)(64bit) Error: Package: 1:NetworkManager-1.4.0-14.el7_3.x86_64 (updates) Requires: glib2 >= 2.46.2 Installed: glib2-2.42.2-5.el7.x86_64 (@anaconda) glib2 = 2.42.2-5.el7 Error: Package: policycoreutils-2.5-11.el7_3.x86_64 (updates) Requires: libsepol.so.1(LIBSEPOL_1.0)(64bit) Error: kernel conflicts with kmod-20-5.el7.x86_64 Error: Package: spice-glib-0.31-6.el7_3.2.x86_64 (updates) Requires: spice-protocol >= 0.12.11-1 Available: spice-protocol-0.12.6-2.el7.noarch (base) spice-protocol = 0.12.6-2.el7 Error: Package: 1:java-1.7.0-openjdk-headless-1.7.0.121-2.6.8.0.el7_3.x86_64 (updates) Requires: copy-jdk-configs >= 1.1-3 Error: Package: 1:java-1.8.0-openjdk-headless-1.8.0.111-2.b15.el7_3.x86_64 (updates) Requires: copy-jdk-configs >= 1.1-3 Error: Package: policycoreutils-python-2.5-11.el7_3.x86_64 (updates) Requires: libsepol.so.1(LIBSEPOL_1.0)(64bit) Error: Package: 7:lvm2-2.02.166-1.el7_3.2.x86_64 (updates) Requires: device-mapper-persistent-data >= 0.6.3-1 Installed: device-mapper-persistent-data-0.5.5-1.el7.x86_64 (@anaconda) device-mapper-persistent-data = 0.5.5-1.el7 Error: Package: kernel-3.10.0-514.6.1.el7.x86_64 (updates) Requires: linux-firmware >= 20160830-49 Installed: linux-firmware-20150904-43.git6ebf5d5.el7.noarch (@anaconda) linux-firmware = 20150904-43.git6ebf5d5.el7 Error: Package: nss-util-3.21.3-1.1.el7_3.x86_64 (updates) Requires: nspr >= 4.11.0-1 Installed: nspr-4.10.8-2.el7_1.x86_64 (@anaconda) nspr = 4.10.8-2.el7_1 Error: Package: policycoreutils-python-2.5-11.el7_3.x86_64 (updates) Requires: setools-libs >= 3.3.8-1 Installed: setools-libs-3.3.7-46.el7.x86_64 (@anaconda) setools-libs = 3.3.7-46.el7 Error: Package: policycoreutils-2.5-11.el7_3.x86_64 (updates) Requires: libsepol.so.1(LIBSEPOL_1.1)(64bit) Error: Package: policycoreutils-2.5-11.el7_3.x86_64 (updates) Requires: libselinux-utils >= 2.5-6 Installed: libselinux-utils-2.2.2-6.el7.x86_64 (@anaconda) libselinux-utils = 2.2.2-6.el7 Error: Package: spice-glib-0.31-6.el7_3.2.x86_64 (updates) Requires: usbredir >= 0.6-8 Installed: usbredir-0.6-7.el7.x86_64 (@anaconda) usbredir = 0.6-7.el7 Error: Package: policycoreutils-2.5-11.el7_3.x86_64 (updates) Requires: libsepol >= 2.5-6 Installed: libsepol-2.1.9-3.el7.x86_64 (@anaconda) libsepol = 2.1.9-3.el7 Error: Package: 1:java-1.7.0-openjdk-headless-1.7.0.121-2.6.8.0.el7_3.x86_64 (updates) Requires: chkconfig >= 1.7 Installed: chkconfig-1.3.61-5.el7.x86_64 (@anaconda) chkconfig = 1.3.61-5.el7 Error: Package: samba-libs-4.4.4-12.el7_3.x86_64 (updates) Requires: libpytalloc-util.so.2(PYTALLOC_UTIL_2.1.6)(64bit) Error: Package: 10:qemu-kvm-1.5.3-126.el7_3.3.x86_64 (updates) Requires: libusbx >= 1.0.19 Installed: libusbx-1.0.15-4.el7.x86_64 (@anaconda) libusbx = 1.0.15-4.el7 Error: Package: nss-3.21.3-2.el7_3.x86_64 (updates) Requires: nspr >= 4.11.0 Installed: nspr-4.10.8-2.el7_1.x86_64 (@anaconda) nspr = 4.10.8-2.el7_1 Error: Package: 1:java-1.8.0-openjdk-headless-1.8.0.111-2.b15.el7_3.x86_64 (updates) Requires: chkconfig >= 1.7 Installed: chkconfig-1.3.61-5.el7.x86_64 (@anaconda) chkconfig = 1.3.61-5.el7 

对于世界我无法弄清楚如何将anaconda的引用replace为更新以及如何解决下列冲突。

最重要的是我不明白为什么会发生,因为在以前的安装使用完全相同的图像,我从来没有同样的问题。

  • Redhat 7桌面到工作站
  • 安装一些python软件包时出现问题
  • 如何删除CentOS 5上不再需要的软件包?
  • YUM更新错误
  • 如何安装RHEL6的主要存储库
  • 如何删除yum的存储库
  • 2 Solutions collect form web for “在CentOS 7中更新Yum时的依赖冲突”

    我有这个问题,我认为这是因为yum更新被打断。

    做一个'百胜千夫所有'和重buildrpm数据库没有帮助。

    第一个冲突是因为我安装了多个版本的kmod。

    如果您执行“rpm -qa kmod”并查看多个版本,请尝试使用“rpm -e kmod-version”卸载旧版本,然后再次运行更新。 您可能需要卸载一些其他冲突的软件包,然后重新安装。 这最终解决了我的问题。

    你的yum储存库彼此不同步。

    您的base知识库正在显示来自CentOS 7.1或7.2的文件(我无法确定哪些),但是您的updates存储库正在显示来自CentOS 7.3的文件。

    可能是因为你的系统中只是有过时的元数据,在这种情况下,你可以通过运行yum clean all然后尝试再次更新来解决这个问题。

    但是更有可能的是,有人对base回购进行了混乱,试图强迫它保持在7.1或7.2。 这是支持的,你应该编辑回购文件/etc/yum.repos.d/CentOS-Base.repo将其恢复到原来的forms。

    服务器问题集锦,包括 Linux(Ubuntu, Centos,Debian等)和Windows Server服务器.