将cURL升级到最新的CentOS 5.8

我需要用CentOS在MediaTemple DV服务器上更新cURL。 我的服务器运行cURL版本:7.15.5和CentOS版本:5.8(最后)。

我见过像yum update curl命令,但只是想确定之前,我开始在我的服务器上运行命令。

我看到这个问题“将cURL升级到CentOS上的最新版本 ”,但是我看到很多对Linux的参考。

任何帮助将不胜感激!

  • rpm文件夹中的“u”代表什么?
  • 错误从'yum list <package>' - up2date客户端滥用?
  • 如何在RHEL Server 6.3上安装java-1.7.0-openjdk-devel?
  • Redhat 7桌面到工作站
  • 自动删除%preun损坏的RPM?
  • YUM更新错误
  • One Solution collect form web for “将cURL升级到最新的CentOS 5.8”

    运行yum update <package>通常是安全的。 由于从2013年起,最新的cURL的勘误是RHSA-2013-0983 ,我不认为yum upgrade curl在2016年将实际上做任何事情…

    运行yum update <package>通常也不会更改该包的版本 …

    您可能还应该定期运行yum upate而不是定期安装任何其他选项,以安装RHEL / CentOS 5发布的一些安全更新/错误修复 。


    编辑我错过了,你仍然在5.8这是一个从2012年的CentOS发行,因为从未修补。 阅读这个答案为什么这是一个糟糕的想法™。
    如果你的yumconfiguration是正确的, yum update curl可能需要安装一些更新的依赖关系,而这些关系早已过期。

    服务器问题集锦,包括 Linux(Ubuntu, Centos,Debian等)和Windows Server服务器.