木偶不断尝试安装杂种

我使用Puppet来pipe理我的服务器,我正在做的一件事是从Gem安装Mongrel:

package { mongrel: provider => gem, ensure => latest, require => Package[rubygems], } 

但似乎有一些问题,因为木偶不断试图在每次运行安装Mongrel。 我从木偶中得到了很多这样的东西:

 notice: /Stage[main]/Passenger/Package[mongrel]/ensure: ensure changed '1.1.5' to '1.1.5 ruby java x86-mingw32 x86-mswin32-60' 

难道我做错了什么? 这是一个错误? 任何解决方法?

看起来非常像一个错误。 我会提交一个错误报告。

解决方法可能是:

 ensure => "1.1.5" 

确保=>“最新”对于除testing服务器以外的任何东西都是危险的。