试图安装gd,得到冲突错误

我试图安装GD使用sudo yum install php-gd但我得到下面的错误。 我知道我之前遇到过这个问题,但似乎无法回想起我如何解决这个问题。 我在错误的目录? 我在某些时候错误地更新了PHP吗? 我的大脑似乎已经closures了一夜,我无法弄清楚这一个。

– >处理冲突:php55w-common-5.5.8-1.w6.i386冲突php-common <5.5.0

– >完成依赖关系解决scheme

错误:php55w-与php-common-5.3.3-27.el6_5.i686`的常见冲突

谢谢

首先你需要检查你已经安装的PHP版本

#php -v

在此之后,您需要为您的PHP版本findphp-gd软件包,导致您正在尝试php-gd for PHP 5.5。 ,但你(可能)有PHP 5.3。 。 所以你可以尝试:

  1. 我假设你已经安装了REMI或CentALT仓库,所以你可以试试从这些仓库安装pgp-gd。

    #yum安装php-gd

  2. 如果您需要更新版本的PHP == >> PHP GD:

    1. 删除当前的PHP,简单的方法是:

      #rpm -qa | grep php | xargs yum -y删除

    2. 安装你需要的PHP版本:

      #yum安装php55w-common php55w-gd …