需要为本地安装设置哪些PERL环境variables?

我正在运行的Centos 7.2,默认情况下有Perl 5.16。

我的一个用户请求的软件至less需要Perl 5.18,首选5.22。 我在/opt/perl/5.24安装了5.24,使用:

 ./Configure -des -Dprefix=/opt/perl/5.24 -Dotherlibdirs=/opt/perl/5.24/lib/perl5 -Uuseperlio 

我们使用环境模块,我只希望这一个软件能够使用这个Perl版本 – 否则会用行话来说 – “不支持”。

现在需要设置哪些环境variables来使用该软件?

很明显,我会将/opt/perl/5.24/bin追加到$PATH ,但是perl需要/需要什么其他variables – 用于安装模块等? (使用cpanimus)

我可以看到有一个$PERL5LIB和一个$PERL_PATH在各种职位 – 但是这些规范的Perl或只是有关的post有问题?

我不认为你应该需要设置任何环境variables,只要你的Perl安装正确。 只需调用你的perl解释器就足够了。 与perl相关的环境variableslogging在perldoc的perlrun页面上,但是像$PERL5LIB这样的variables只能用来覆盖正常行为。 你不应该在这种情况下设置它们。