安装php-gd时出错

我安装了与remi回购的PHP,现在我想安装PHP GD。 我试过为我的CentOS 7安装php-gd,但是我得到这个错误:

sudo yum install php-gd Loaded plugins: fastestmirror, langpacks Loading mirror speeds from cached hostfile * base: repos.redrockhost.com * epel: mirrors.syringanetworks.net * extras: centos.sonn.com * updates: mirror.compevo.com Resolving Dependencies --> Running transaction check ---> Package php-gd.x86_64 0:5.4.16-23.el7_0.3 will be installed --> Processing Dependency: php-common(x86-64) = 5.4.16-23.el7_0.3 for package: php-gd-5.4.16-23.el7_0.3.x86_64 --> Processing Dependency: libt1.so.5()(64bit) for package: php-gd-5.4.16-23.el7_0.3.x86_64 --> Running transaction check ---> Package php-gd.x86_64 0:5.4.16-23.el7_0.3 will be installed --> Processing Dependency: php-common(x86-64) = 5.4.16-23.el7_0.3 for package: php-gd-5.4.16-23.el7_0.3.x86_64 ---> Package t1lib.x86_64 0:5.1.2-14.el7 will be installed --> Finished Dependency Resolution Error: Package: php-gd-5.4.16-23.el7_0.3.x86_64 (base) Requires: php-common(x86-64) = 5.4.16-23.el7_0.3 Installed: php-common-5.5.17-2.el7.remi.x86_64 (@remi-php55) php-common(x86-64) = 5.5.17-2.el7.remi Available: php-common-5.4.16-23.el7_0.3.x86_64 (base) php-common(x86-64) = 5.4.16-23.el7_0.3 You could try using --skip-broken to work around the problem You could try running: rpm -Va --nofiles --nodigest 

有人可以帮我吗?

这个问题似乎是你可能需要启用remi-php55的回购,如果你还没有 – 我敢肯定你会运行一些像yum install php-gd --enablerepo=remi,remi-php55