如何启用php4只,没有php5

我有一个Ubuntu 9.10,Apache 2,Mysql 5和PHP5 LAMP服务器。 我想禁用PHP5并只使用PHP4。 任何人都可以解释如何做到这一点?

我这样做是因为我需要模拟类似于传统服务器的环境。

谢谢

Ubuntu 9.10中没有PHP4包。

我想你可以从http://www.php.net/releases/下载PHP4源代码并自己编译。

我自己我会下载仍然支持的Ubuntu 6.06,它有PHP4包,并将其安装在虚拟机中。 这样我就可以玩旧的东西,而不会与我目前的系统产生冲突。 你可以在http://releases.ubuntu.com/6.06/findUbuntu 6.06的iso文件。

您可以添加旧版本的repos,并安装PHP4软件包,类似于andol所说的。