无法让PostgreSQL在Debian Lenny中运行

我试图使用包pipe理器在Debian Lenny(kernel 2.6.26-2-686)上安装PostgreSQL 8.3:

sudo apt-get install postgresql-8.3 postgresql-client-8.3 postgresql-contrib-8.3 postgresql-common

部署postgresql-common包时,会显示以下警告:

supported_versions:警告:未知的Debian版本:5.0.4

我想知道这是否与我在下面描述的问题有关。

接下来,我尝试启动数据库服务器,但没有任何影响,也没有生成任何日志。

sudo /etc/init.d/postgresql-8.3启动

有没有人知道可能会发生什么?

更新 :这些是sources.list的内容:

deb http://security.debian.org/lenny/updates main contrib deb-src http://security.debian.org/lenny/updates main contrib deb http://volatile.debian.org/debian-volatile lenny/volatile main contrib deb-src http://volatile.debian.org/debian-volatile lenny/volatile main contrib deb http://http.us.debian.org/debian stable main contrib non-free 

解决方法 :感谢@lg指出这个特定的软件包是越野车。 一个可能的解决方法是从Debian的backports存储库安装PostgreSQL 8.4:

将以下行添加到/etc/apt/sources.list中:

deb http://www.backports.org/debian lenny-backports主要贡献非自由的

并执行:

 apt-get install debian-backports-keyring apt-get update apt-get -t lenny-backports install postgresql-8.4 

服务器然后自动启动。

我发现这个错误 ,它从版本95解决,但你正在安装稳定版本(94)。

你在使用哪个版本库? 我想你是安装一个错误的版本postgresql包。